summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-03-20 15:43:04 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-03-20 15:43:04 -0500
commit3098b4658034fd8d6603e72707c76c9fd459211a (patch)
tree5717f269b82a3dd35072d9e249008791f0de0802 /dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild
parentsci-misc/boinc: New ebuild boinc-7.6.31.ebuild (diff)
downloadgentoo-3098b4658034fd8d6603e72707c76c9fd459211a.tar.gz
gentoo-3098b4658034fd8d6603e72707c76c9fd459211a.tar.bz2
gentoo-3098b4658034fd8d6603e72707c76c9fd459211a.zip
dev-python/pytest-raisesregexp: add version 2.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild')
-rw-r--r--dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild b/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild
new file mode 100644
index 000000000000..6f09d3b561b9
--- /dev/null
+++ b/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Simple pytest plugin to look for regex in Exceptions"
+HOMEPAGE="https://github.com/Walkman/pytest_raisesregexp"
+SRC_URI="https://github.com/kissgyorgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${CDEPEND} )
+"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/py[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ distutils_install_for_testing
+ ${PYTHON} -m pytest || die "Tests failed under ${EPYTHON}"
+}