summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 09:32:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 09:32:38 +0100
commit7888ee53660ad59b61b869b0a92f5ec2ea48eccd (patch)
treecb6217ce345fb2fb85962cd0a80a87a133939a16 /dev-python/pytest-regressions
parentdev-libs/libretls: Bump to 3.5.0 (diff)
downloadgentoo-7888ee53660ad59b61b869b0a92f5ec2ea48eccd.tar.gz
gentoo-7888ee53660ad59b61b869b0a92f5ec2ea48eccd.tar.bz2
gentoo-7888ee53660ad59b61b869b0a92f5ec2ea48eccd.zip
dev-python/pytest-regressions: Make pandas test-dep optional
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-regressions')
-rw-r--r--dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild19
1 files changed, 18 insertions, 1 deletions
diff --git a/dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild b/dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild
index 8cf9cc85818f..2207079a0ece 100644
--- a/dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild
+++ b/dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild
@@ -26,10 +26,27 @@ BDEPEND="
test? (
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/tox[${PYTHON_USEDEP}]
)"
distutils_enable_tests pytest
distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_filenames.py::test_foo
+ tests/test_filenames.py::TestClass::test_foo
+ tests/test_filenames.py::TestClassWithIgnoredName::test_foo
+ )
+ EPYTEST_IGNORE+=(
+ tests/test_dataframe_regression.py
+ tests/test_num_regression.py
+ )
+ fi
+
+ epytest
+}