summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-17 09:23:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-17 10:30:56 +0200
commite715ecf79bd6e2d4eb77f6c4acce9fcb8d0d5055 (patch)
tree1fb6393570832ec52ebe052c2ba24983e5ebd32b /dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
parentkde-apps/kolf: keyword 21.08.1 for ~riscv (diff)
downloadgentoo-e715ecf79bd6e2d4eb77f6c4acce9fcb8d0d5055.tar.gz
gentoo-e715ecf79bd6e2d4eb77f6c4acce9fcb8d0d5055.tar.bz2
gentoo-e715ecf79bd6e2d4eb77f6c4acce9fcb8d0d5055.zip
dev-python/pytest-rerunfailures: Bump to 10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
new file mode 100644
index 000000000000..369054f3e717
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="https://pypi.org/project/pytest-rerunfailures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ >=dev-python/pytest-5.0[${PYTHON_USEDEP}]
+ test? ( !!dev-python/flaky )
+"
+
+distutils_enable_tests pytest