summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-02 18:15:54 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-02 18:18:56 -0800
commit0d016094b94dcea6afd631d6a2675de51c7667d3 (patch)
tree16738061d136965a645fe02f76c92f9e4d88723d /dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild
parentdev-python/colorama-0.4.1: Add py38 (diff)
downloadgentoo-0d016094b94dcea6afd631d6a2675de51c7667d3.tar.gz
gentoo-0d016094b94dcea6afd631d6a2675de51c7667d3.tar.bz2
gentoo-0d016094b94dcea6afd631d6a2675de51c7667d3.zip
dev-python/pytest-rerunfailures-8.0: Version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild
new file mode 100644
index 000000000000..e362572bb4c1
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="https://pypi.org/project/pytest-rerunfailures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.4[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest