summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-02-27 14:01:52 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-02-27 17:54:39 -0800
commitf3164d810d3f0995234552ff4ae6dd4da645eed5 (patch)
tree3f712c6f3c61069d6f0a7c13e45ed81ce4621d99 /dev-python/pytest-salt
parentdev-python/fusil: remove last-rited package (diff)
downloadgentoo-f3164d810d3f0995234552ff4ae6dd4da645eed5.tar.gz
gentoo-f3164d810d3f0995234552ff4ae6dd4da645eed5.tar.bz2
gentoo-f3164d810d3f0995234552ff4ae6dd4da645eed5.zip
dev-python/pytest-salt: Version bump to 2019.2.1_p1
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-salt')
-rw-r--r--dev-python/pytest-salt/Manifest2
-rw-r--r--dev-python/pytest-salt/pytest-salt-0.1_pre20170731.ebuild18
-rw-r--r--dev-python/pytest-salt/pytest-salt-2019.2.1_p1.ebuild23
3 files changed, 24 insertions, 19 deletions
diff --git a/dev-python/pytest-salt/Manifest b/dev-python/pytest-salt/Manifest
index eb514be58a00..5e84b8c39769 100644
--- a/dev-python/pytest-salt/Manifest
+++ b/dev-python/pytest-salt/Manifest
@@ -1 +1 @@
-DIST pytest-salt-0.1_pre20170731.tar.xz 30084 BLAKE2B a86159900aa4710d261e117aa745010ac2d977d852cd97ee366e2871d4c6a3e12c9769481d1de697d8df10f4c8b1f3366b93807de05257ffec590b5028ab2dcb SHA512 700072c9afef3c78ea4fc5cdbc54e28fb9d0635744cea07fa187cf21665f211eda05318d6a945c1dd6cc7a944bdf608ae2d8f78448d0667cba4984fc2fa2c75e
+DIST pytest-salt-2019.2.1.post1.tar.gz 63824 BLAKE2B 684e1dee6df8f7459bfa1747ea017973d72bc69b87d22c65509ecada47469a94ce410034004a5df1396d5ed05557ddec90e34cb18792235babb5e0cf6d72d776 SHA512 7b9939c3bd1cbcb6d6d0b086c39e02deadd8b3c6fcc359924af7fa5afc2e443b927269b82aa5575413e4e6bbc052f4035fb17ab68dac59ea309320c0a647d36d
diff --git a/dev-python/pytest-salt/pytest-salt-0.1_pre20170731.ebuild b/dev-python/pytest-salt/pytest-salt-0.1_pre20170731.ebuild
deleted file mode 100644
index 6e5e664f9a1b..000000000000
--- a/dev-python/pytest-salt/pytest-salt-0.1_pre20170731.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1
-
-DESCRIPTION="PyTest Salt Plugin"
-HOMEPAGE="https://github.com/saltstack/pytest-salt"
-SRC_URI="mirror://gentoo/${P}.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
diff --git a/dev-python/pytest-salt/pytest-salt-2019.2.1_p1.ebuild b/dev-python/pytest-salt/pytest-salt-2019.2.1_p1.ebuild
new file mode 100644
index 000000000000..9b2fd5530cb6
--- /dev/null
+++ b/dev-python/pytest-salt/pytest-salt-2019.2.1_p1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+MY_PV="${PV/_p/.post}"
+inherit distutils-r1
+
+DESCRIPTION="PyTest Salt Plugin"
+HOMEPAGE="https://github.com/saltstack/pytest-salt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/psutil-4.2.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"