summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-22 12:08:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-22 12:46:22 +0200
commit82808df331c644fe2336cb701290345a3a4933a9 (patch)
tree674c63fb0b302aa4f43487fe6e6b1711cb13eedd /dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild
parentdev-python/cherrypy: Use PEP517 build (diff)
downloadgentoo-82808df331c644fe2336cb701290345a3a4933a9.tar.gz
gentoo-82808df331c644fe2336cb701290345a3a4933a9.tar.bz2
gentoo-82808df331c644fe2336cb701290345a3a4933a9.zip
dev-python/pytest-services: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild')
-rw-r--r--dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild b/dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..9cccb98c013d
--- /dev/null
+++ b/dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of fixtures and utility functions to run service processes for pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-services/
+ https://pypi.org/project/pytest-services/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-services/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/zc-lockfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ net-misc/memcached
+ !dev-python/pytest-salt
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/pytest-services-2.0.1-no-mysql.patch"
+ "${FILESDIR}/pytest-services-2.0.1-lockdir.patch"
+)
+
+python_test() {
+ epytest -p no:xvfb
+}