summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-01-03 13:25:05 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-01-03 20:48:29 -0800
commit1687915326fb47e96d1dc4c671fd52f707b1bc9b (patch)
tree5d2f8a6c0545dfed9445bd3349219a5025722492 /dev-python/pytest-shutil/pytest-shutil-1.2.4.ebuild
parentdev-python/setuptools-git: Bump, adding python-3.5 (diff)
downloadgentoo-1687915326fb47e96d1dc4c671fd52f707b1bc9b.tar.gz
gentoo-1687915326fb47e96d1dc4c671fd52f707b1bc9b.tar.bz2
gentoo-1687915326fb47e96d1dc4c671fd52f707b1bc9b.zip
dev-python/pytest-shutil: New pkg, dep of dev-python/pytest-vitualenv
Inirect dep for buildbot tests Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
Diffstat (limited to 'dev-python/pytest-shutil/pytest-shutil-1.2.4.ebuild')
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.2.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.2.4.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.2.4.ebuild
new file mode 100644
index 000000000000..2f607b10e366
--- /dev/null
+++ b/dev-python/pytest-shutil/pytest-shutil-1.2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-shutil"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}