summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-05 23:18:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-06 00:54:02 +0200
commit1cbd13afa14a227b1434e04a02153b338bf0551c (patch)
tree233a9a3eb8a228888e1ab8749cea37361ca6b275 /dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild
parentsys-devel/clang-runtime: Bump to 12.0.1-rc4 (diff)
downloadgentoo-1cbd13afa14a227b1434e04a02153b338bf0551c.tar.gz
gentoo-1cbd13afa14a227b1434e04a02153b338bf0551c.tar.bz2
gentoo-1cbd13afa14a227b1434e04a02153b338bf0551c.zip
dev-python/pytest-shutil: Remove stale contextlib2 dep
contextlib2 is needed only on Python 2. Strip the unconditional dep from setup.py (upstream made it conditional in newer git). Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild')
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild
new file mode 100644
index 000000000000..8ee1fa7aea61
--- /dev/null
+++ b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A goodie-bag of unix shell and environment tools for py.test"
+HOMEPAGE="https://github.com/man-group/pytest-plugins https://pypi.org/project/pytest-shutil/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+"
+# block pytest plugins that will be broken by the upgrade
+RDEPEND+="
+ !<dev-python/pytest-virtualenv-1.7.0-r1[python_targets_python2_7(-)]
+"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # remove unnecessary deps
+ # (contextlib2 is not used in py3)
+ sed -i -e '/path\.py/d' -e '/contextlib2/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}