summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-03-15 14:53:06 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-03-16 17:45:21 -0700
commit71f67ae6f1dda3eb11be081235200109598e8a9b (patch)
tree474d40a79a3c7b151671ae7f59a44f3024fb59be /dev-python/pytest-shutil
parentnet-libs/libgadu: Version bump 1.12.2 (diff)
downloadgentoo-71f67ae6f1dda3eb11be081235200109598e8a9b.tar.gz
gentoo-71f67ae6f1dda3eb11be081235200109598e8a9b.tar.bz2
gentoo-71f67ae6f1dda3eb11be081235200109598e8a9b.zip
dev-python/pytest-shutil: Version bump
Package-Manager: Portage-2.3.4_p1, Repoman-2.3.2_p2
Diffstat (limited to 'dev-python/pytest-shutil')
-rw-r--r--dev-python/pytest-shutil/Manifest1
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-shutil/Manifest b/dev-python/pytest-shutil/Manifest
index b5f0e6afb271..4d6ce382d7ad 100644
--- a/dev-python/pytest-shutil/Manifest
+++ b/dev-python/pytest-shutil/Manifest
@@ -1 +1,2 @@
DIST pytest-shutil-1.2.4.tar.gz 16327 SHA256 a3fc464033dc39396a67eac9e228a0682e866654b8017819b2511bdbd8ed751f SHA512 9ec6baa3cf53bb80103b1dfbf6c26794090c26dd74b29cd19e76b1037c6939538c7b05ea16368a76cce6969216c291e27b00833a990268239bfd2222f69ddfb4 WHIRLPOOL 5f52535feadf11c5aa33b69cc8d35d361d7345611b9239a8282a94d58bfb4163c1207a60cb3d38998ba777e8b9912a3a63cfa0b820962ce84dba8a5ba8068642
+DIST pytest-shutil-1.2.8.tar.gz 17051 SHA256 924accaec3f3781416139e580386ab4f849cb8662bc1072405a81d3a5e56bf3d SHA512 de73b2c350709e356810f58d2a8a4c7668144701639c45a0690081e707e7147762f650af2e9f826429d0488655dae0e3366611da5e8e3ecd0c6382e215170b2d WHIRLPOOL 433fb2ec4db71cb958f1f7b8278c1fb88de5e56369dec04910947d611f779dea9fb4e5282adeac5014fe601ca19046733039b6cc6733504f94c0503ff57b9ec5
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild
new file mode 100644
index 000000000000..13b1847ff9cc
--- /dev/null
+++ b/dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-shutil"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}