summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-20 23:10:38 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-21 01:12:26 -0400
commitad02021a2b7af45cfa235baa25886ac1bfdac833 (patch)
treec7b15dae9b35b01d4b11d478474f3504a45fd34b /dev-python/pytest-shutil
parentdev-python/pytest-fixture-config: version bump to 1.2.11 (diff)
downloadgentoo-ad02021a2b7af45cfa235baa25886ac1bfdac833.tar.gz
gentoo-ad02021a2b7af45cfa235baa25886ac1bfdac833.tar.bz2
gentoo-ad02021a2b7af45cfa235baa25886ac1bfdac833.zip
dev-python/pytest-shutil: version bump to 1.2.11
Diffstat (limited to 'dev-python/pytest-shutil')
-rw-r--r--dev-python/pytest-shutil/Manifest1
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-shutil/Manifest b/dev-python/pytest-shutil/Manifest
index 4d6ce382d7ad..f4be5c4fafe4 100644
--- a/dev-python/pytest-shutil/Manifest
+++ b/dev-python/pytest-shutil/Manifest
@@ -1,2 +1,3 @@
+DIST pytest-shutil-1.2.11.tar.gz 18310 SHA256 ace5250c09377f01e62bd50d33bc959fc66ee0123f7b0b10bc440b35d1644494 SHA512 2a998218bb997a6ceb277965e2f150b2d7722ba518f579154f804568f552e2c41ced9a491c1745382dc119d0b92f3ea993ae77a61851809aae59a1e17501bde8 WHIRLPOOL 9deba2d3d1c0ce708ce4ad2aea7e5a918752df2ac80c87b9852ff5930ef3f99e464634073c6cb9c3e905800ae2450ef20fcbe878ff49debee31408c5e025ac37
DIST pytest-shutil-1.2.4.tar.gz 16327 SHA256 a3fc464033dc39396a67eac9e228a0682e866654b8017819b2511bdbd8ed751f SHA512 9ec6baa3cf53bb80103b1dfbf6c26794090c26dd74b29cd19e76b1037c6939538c7b05ea16368a76cce6969216c291e27b00833a990268239bfd2222f69ddfb4 WHIRLPOOL 5f52535feadf11c5aa33b69cc8d35d361d7345611b9239a8282a94d58bfb4163c1207a60cb3d38998ba777e8b9912a3a63cfa0b820962ce84dba8a5ba8068642
DIST pytest-shutil-1.2.8.tar.gz 17051 SHA256 924accaec3f3781416139e580386ab4f849cb8662bc1072405a81d3a5e56bf3d SHA512 de73b2c350709e356810f58d2a8a4c7668144701639c45a0690081e707e7147762f650af2e9f826429d0488655dae0e3366611da5e8e3ecd0c6382e215170b2d WHIRLPOOL 433fb2ec4db71cb958f1f7b8278c1fb88de5e56369dec04910947d611f779dea9fb4e5282adeac5014fe601ca19046733039b6cc6733504f94c0503ff57b9ec5
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild
new file mode 100644
index 000000000000..9e003f9243ec
--- /dev/null
+++ b/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A goodie-bag of unix shell and environment tools for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-shutil"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+"
+
+python_test() {
+ esetup.py test
+}