summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-16 15:21:36 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-16 15:37:52 +0100
commitcdcd531b10f313031a2dd3e230ad35ecf8942e3e (patch)
treee9d2eae537ffd44d0145f0ea2b9981a5b0d5362a /dev-python/pytest-shutil
parentdev-python/urllib3: Replace python_gen_usedep (diff)
downloadgentoo-cdcd531b10f313031a2dd3e230ad35ecf8942e3e.tar.gz
gentoo-cdcd531b10f313031a2dd3e230ad35ecf8942e3e.tar.bz2
gentoo-cdcd531b10f313031a2dd3e230ad35ecf8942e3e.zip
dev-python/pytest-shutil: Set DISTUTILS_USE_SETUPTOOLS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-shutil')
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.7.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.7.0.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.7.0.ebuild
index d7a72037c4a9..701c5f8395ec 100644
--- a/dev-python/pytest-shutil/pytest-shutil-1.7.0.ebuild
+++ b/dev-python/pytest-shutil/pytest-shutil-1.7.0.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
inherit distutils-r1
@@ -14,6 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~mips ~s390 ~sparc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]
@@ -29,8 +32,6 @@ BDEPEND="
${RDEPEND}
"
-RESTRICT="!test? ( test )"
-
python_prepare_all() {
# keeps trying to install this in tests
sed -i 's:path.py::' setup.py || die