summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-08 13:09:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-08 13:25:17 +0200
commit76b054ac2fb339a1ab12b0daa88efcee8d708043 (patch)
tree6397d49003f34577961d9b1c5f99d20518d2484e /dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r2.ebuild
parentdev-python/pytest-helpers-namespace: Remove setuptools-decl* dep (diff)
downloadgentoo-76b054ac2fb339a1ab12b0daa88efcee8d708043.tar.gz
gentoo-76b054ac2fb339a1ab12b0daa88efcee8d708043.tar.bz2
gentoo-76b054ac2fb339a1ab12b0daa88efcee8d708043.zip
dev-python/pytest-skip-markers: Remove setuptools-decl* dep
Remove the dep on dev-python/setuptools-declarative-requirements. It's non-critical and breaks random test suites through random output from setuptools. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r2.ebuild')
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r2.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r2.ebuild
new file mode 100644
index 000000000000..864d4576d4f6
--- /dev/null
+++ b/dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Pytest plugin which implements a few useful skip markers"
+HOMEPAGE="
+ https://pytest-skip-markers.readthedocs.io/en/latest/
+ https://github.com/saltstack/pytest-skip-markers
+"
+SRC_URI="
+ https://github.com/saltstack/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}