summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-17 08:36:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-17 09:22:31 +0200
commitdf07582aed98c30a3008ce2fc8b9beb70e0a20d8 (patch)
tree3a81ee0166f07b9aa87428aed79c5abdbe9fb54a /dev-python/pytest-subtesthack
parentdev-python/nose2: Bump to 0.12.0 (diff)
downloadgentoo-df07582aed98c30a3008ce2fc8b9beb70e0a20d8.tar.gz
gentoo-df07582aed98c30a3008ce2fc8b9beb70e0a20d8.tar.bz2
gentoo-df07582aed98c30a3008ce2fc8b9beb70e0a20d8.zip
dev-python/pytest-subtesthack: Bump to 0.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/Manifest1
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.2.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-subtesthack/Manifest b/dev-python/pytest-subtesthack/Manifest
index ec39bdad2850..eb068bca34c4 100644
--- a/dev-python/pytest-subtesthack/Manifest
+++ b/dev-python/pytest-subtesthack/Manifest
@@ -1 +1,2 @@
DIST pytest-subtesthack-0.1.2.tar.gz 2669 BLAKE2B f1f5a052f9418732de4a97ff438d280d177860439e667e29ff0d0503740e009c88046b5ba859884e5fa9e958ea1be7388d7fc6838c19e44075ab0ef757ee41c7 SHA512 ddb7b0c27f912bec31e58ddc54930e229755df8980d146c861f7f1c766ae742b4f1552117d89638bdbd443f22890262320a56565954ebc6deeae6184f459a5a8
+DIST pytest-subtesthack-0.2.0.gh.tar.gz 2886 BLAKE2B e4e34ff73c7dfe92bed94d40fef168a3420879ba4a28eccb66ae7549d895b0ca7885be57178a6403661b57578f55ac3c5dbcaa090d2b658da770e0cabb0f3a75 SHA512 8b4f5ee2b07a8bcfa11934f5f207b9418810a708be7b8ccc0f19a4a4b979bbc60e993f0f2a5158482bc0162364bc96717e1ecda6743832ba121dfef9cfca9dd5
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.2.0.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.2.0.ebuild
new file mode 100644
index 000000000000..734224e8f321
--- /dev/null
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
+HOMEPAGE="
+ https://github.com/untitaker/pytest-subtesthack/
+ https://pypi.org/project/pytest-subtesthack/
+"
+SRC_URI="
+ https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest