summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-03-30 11:10:57 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-03-30 18:28:06 -0700
commit043eaaf5662e31b5fe34c3f6dbf90514c996d0bd (patch)
treeaa6f380dd94d029dd8faabce27aac212245f8dc8 /dev-python/pytest-system-statistics
parentdev-python/pytest-shell-utilities: initial import (diff)
downloadgentoo-043eaaf5662e31b5fe34c3f6dbf90514c996d0bd.tar.gz
gentoo-043eaaf5662e31b5fe34c3f6dbf90514c996d0bd.tar.bz2
gentoo-043eaaf5662e31b5fe34c3f6dbf90514c996d0bd.zip
dev-python/pytest-system-statistics: initial import
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-system-statistics')
-rw-r--r--dev-python/pytest-system-statistics/Manifest1
-rw-r--r--dev-python/pytest-system-statistics/metadata.xml11
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild49
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pytest-system-statistics/Manifest b/dev-python/pytest-system-statistics/Manifest
new file mode 100644
index 000000000000..550382e4b516
--- /dev/null
+++ b/dev-python/pytest-system-statistics/Manifest
@@ -0,0 +1 @@
+DIST pytest-system-statistics-1.0.2.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
diff --git a/dev-python/pytest-system-statistics/metadata.xml b/dev-python/pytest-system-statistics/metadata.xml
new file mode 100644
index 000000000000..227706a29106
--- /dev/null
+++ b/dev-python/pytest-system-statistics/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Patrick McLean</name>
+ <email>chutzpah@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-system-statistics</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
new file mode 100644
index 000000000000..c2507c3eaf70
--- /dev/null
+++ b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
+HOMEPAGE="
+ https://pypi.org/project/pytest-system-statistics/
+ https://github.com/saltstack/pytest-system-statistics
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -k 'not proc_sys_stats'
+}