summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pytest-timeout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest1
-rw-r--r--dev-python/pytest-timeout/metadata.xml8
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-0.4.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
new file mode 100644
index 000000000000..7717c07d851c
--- /dev/null
+++ b/dev-python/pytest-timeout/Manifest
@@ -0,0 +1 @@
+DIST pytest-timeout-0.4.tar.gz 10204 SHA256 d5900aaa94af5cb2d06ed806b1e636255e65a8a26eccecccd2b9a9d6123d50d5 SHA512 07031d64012e683064cd0bf2cef1d7209f02085e07dd8c7dfc704270d1e6ecf9679c639d529586c7d52d9425244a05ac362a7cd0092ca1f162a54539f58286e4 WHIRLPOOL b4befc271e378246d3e9fdd23a931fa400a981f79e90b0d44bbd533bea2be976fb4fcf73f6aa552d129e6945d82880bdf7bbf08c653c787913a8b782be54ab51
diff --git a/dev-python/pytest-timeout/metadata.xml b/dev-python/pytest-timeout/metadata.xml
new file mode 100644
index 000000000000..dc17bfcfbb97
--- /dev/null
+++ b/dev-python/pytest-timeout/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pytest-timeout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-timeout/pytest-timeout-0.4.ebuild b/dev-python/pytest-timeout/pytest-timeout-0.4.ebuild
new file mode 100644
index 000000000000..0db83fe67a36
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to abort hanging tests"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-timeout"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/pytest"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ ${EPYTHON} test_pytest_timeout.py || die
+}