summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 12:44:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 13:09:51 +0200
commit048535d07aa6da675ad83490fe9a927bb95584d0 (patch)
tree0a90c192f5cd324e98c58fda1c1710491929a308 /dev-python/pytest-toolbox
parentdev-python/pytest-toolbox: Enable pypy3 (diff)
downloadgentoo-048535d07aa6da675ad83490fe9a927bb95584d0.tar.gz
gentoo-048535d07aa6da675ad83490fe9a927bb95584d0.tar.bz2
gentoo-048535d07aa6da675ad83490fe9a927bb95584d0.zip
dev-python/pytest-toolbox: Switch to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-toolbox')
-rw-r--r--dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild b/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild
new file mode 100644
index 000000000000..6a9dd618bd61
--- /dev/null
+++ b/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Numerous useful plugins for pytest"
+HOMEPAGE="https://pypi.org/project/pytest-toolbox/ https://github.com/samuelcolvin/pytest-toolbox/"
+SRC_URI="
+ https://github.com/samuelcolvin/pytest-toolbox/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}