summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-09 14:39:36 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-09 15:39:09 +0200
commitf0c784a9e10dc0daf0036e3adaab760947c55eaf (patch)
tree2e6f61dbe13507c6b768b2767f8c3f6a2ea71f96 /dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild
parentdev-util/plan9port: new snapshot (diff)
downloadgentoo-f0c784a9e10dc0daf0036e3adaab760947c55eaf.tar.gz
gentoo-f0c784a9e10dc0daf0036e3adaab760947c55eaf.tar.bz2
gentoo-f0c784a9e10dc0daf0036e3adaab760947c55eaf.zip
dev-python/pytest-tornasync: import from ::sci
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild')
-rw-r--r--dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild
new file mode 100644
index 000000000000..7beeaea50ebf
--- /dev/null
+++ b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for testing Python 3.5+ Tornado code"
+HOMEPAGE="https://github.com/eukaryote/pytest-tornasync"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P//_p/.post}.tar.gz"
+S="${WORKDIR}/${P//_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: fix this
+# E ImportError: cannot import name 'MESSAGE' from 'test'
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install the license file
+ sed -i -e '/LICENSE/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}