summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-08 07:31:48 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-08 09:24:56 +0100
commite36aad5a9b8069e9658239211a02685262ac5b82 (patch)
tree9c06be60680220ccf4fc21b82fdf47944e65ce63 /dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r1.ebuild
parentapp-cdr/xfburn: Bump to 0.6.2 (diff)
downloadgentoo-e36aad5a9b8069e9658239211a02685262ac5b82.tar.gz
gentoo-e36aad5a9b8069e9658239211a02685262ac5b82.tar.bz2
gentoo-e36aad5a9b8069e9658239211a02685262ac5b82.zip
dev-python/pytest-virtualenv: Revbump to drop py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r1.ebuild')
-rw-r--r--dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r1.ebuild b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..6799b9022f4b
--- /dev/null
+++ b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/man-group/pytest-plugins https://pypi.org/project/pytest-virtualenv/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-shutil[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py