summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-23 10:56:05 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-23 11:35:50 +0100
commit8711c0b2bdf8ff2de241704f790da31aa8dc62b8 (patch)
tree2486a76a520c386ecda99682b833dbba83dc06df /dev-python/pytest-xdist/pytest-xdist-1.30.0.ebuild
parentdev-python/filelock: Bump to 3.0.12, py3.8 (diff)
downloadgentoo-8711c0b2bdf8ff2de241704f790da31aa8dc62b8.tar.gz
gentoo-8711c0b2bdf8ff2de241704f790da31aa8dc62b8.tar.bz2
gentoo-8711c0b2bdf8ff2de241704f790da31aa8dc62b8.zip
dev-python/pytest-xdist: Bump to 1.30.0, py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-1.30.0.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.30.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.30.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.30.0.ebuild
new file mode 100644
index 000000000000..75de4e5bfc87
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.30.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.4[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv testing || die "Tests failed under ${EPYTHON}"
+}