summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-17 08:03:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-17 08:39:59 +0200
commit58ae57d08931ff6ffd5ac130661340fc76cc1636 (patch)
tree61fde769b1055e50889706393149e9c4bff79940 /dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
parentdev-python/psycopg: Bump to 2.9.1 (diff)
downloadgentoo-58ae57d08931ff6ffd5ac130661340fc76cc1636.tar.gz
gentoo-58ae57d08931ff6ffd5ac130661340fc76cc1636.tar.bz2
gentoo-58ae57d08931ff6ffd5ac130661340fc76cc1636.zip
dev-python/pytest-xdist: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
new file mode 100644
index 000000000000..127050a2150e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# pytest-xdist >= 2 fails with pytest < 6
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-services-conflict.patch
+)
+
+distutils_enable_tests --install pytest