summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-10 18:18:20 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-10 19:11:51 +0200
commitf04fdd1f47b05612c9bfdaace27872df8df7e6b0 (patch)
treeb994d6b55fb3b3f3e4c13973a7895d26ce7d6ddc /dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild
parentdev-python/pytest-forked: add 1.4.0 (diff)
downloadgentoo-f04fdd1f47b05612c9bfdaace27872df8df7e6b0.tar.gz
gentoo-f04fdd1f47b05612c9bfdaace27872df8df7e6b0.tar.bz2
gentoo-f04fdd1f47b05612c9bfdaace27872df8df7e6b0.zip
dev-python/pytest-xdist: add 2.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild
new file mode 100644
index 000000000000..25372acff9aa
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# pytest-xdist >= 2 fails with pytest < 6
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ distutils_install_for_testing
+ epytest
+}