summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-13 06:00:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-13 06:46:07 +0200
commit1fb80beac274a2096af619d27e5c665772566791 (patch)
tree6711c2ae88de612b633433487d6d8fdc852419a1 /dev-python/pytest-xdist
parentdev-python/sphinx: Bump to 7.0.1 (diff)
downloadgentoo-1fb80beac274a2096af619d27e5c665772566791.tar.gz
gentoo-1fb80beac274a2096af619d27e5c665772566791.tar.bz2
gentoo-1fb80beac274a2096af619d27e5c665772566791.zip
dev-python/pytest-xdist: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 6cc20b41e042..e26145b95ead 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1 +1,2 @@
DIST pytest-xdist-3.2.1.tar.gz 76362 BLAKE2B a5cea5bab1176554bd0d1ebfff5400f60bd43964ae13c7f77ad77fc257db32ba0a0d6f2f3ec16211e48852a6bfd02a0949d618c7f2f6a8da11dd2843d88565a4 SHA512 ea42bea8b4df3d77ef680cba81f76f9f79d0ffcaad6f5f879cc82c53203d36ffe26f233dd6c5d1cbea22b43d257f0f4e6be793116bb281956316c44fc412f9b7
+DIST pytest-xdist-3.3.0.tar.gz 77580 BLAKE2B 5d983fd9c825b76d666a4de36087441a42e32ef11171d2fb4f8dde1f062fda2e664eb766af62012c977b5804f059eb9415fe70030d8a6ffc627833d8e69f1a02 SHA512 15cdfb3db409147fc5107d58bc8e2177a9351d2fde2486523ba17f77754083b75decafe442d5849d1be159a2eb9c20f6c3ec11a8c4cf16ac22d4e98a1f9de452
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.3.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.3.0.ebuild
new file mode 100644
index 000000000000..c3bc7d37a95e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-3.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}