summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-24 08:21:29 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-24 09:01:57 +0200
commit2c185f16591226691a38764183f6b1a15f36308e (patch)
tree9dca1eac37ac1d6d2172949d5b4544e8f04a0c16 /dev-python/pytest-xdist
parentdev-python/urllib3: Bump to 1.26.16 (diff)
downloadgentoo-2c185f16591226691a38764183f6b1a15f36308e.tar.gz
gentoo-2c185f16591226691a38764183f6b1a15f36308e.tar.bz2
gentoo-2c185f16591226691a38764183f6b1a15f36308e.zip
dev-python/pytest-xdist: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild
index cee4b9457782..57cbcf2c12f1 100644
--- a/dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild
+++ b/dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -41,5 +41,16 @@ python_test() {
# since we disabled autoloading, force loading necessary plugins
local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+ [[ ${PV} != 3.3.1 ]] && die "Recheck deselects, please!"
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # failures due to warnings from pytest
+ # https://github.com/pytest-dev/pytest-xdist/issues/914
+ testing/acceptance_test.py::test_config_initialization
+ testing/acceptance_test.py::test_collection_crash
+ )
+ fi
+
epytest
}