summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-26 07:52:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-26 08:38:28 +0200
commit82e65a17b2b9a342b3229afb6c6a672ea49fcfad (patch)
treee66a148500ffdf3e63f7db8a67c810cd78b442f9 /dev-python/pytest-xdist
parentx11-drivers/nvidia-drivers: Fix libdir (diff)
downloadgentoo-82e65a17b2b9a342b3229afb6c6a672ea49fcfad.tar.gz
gentoo-82e65a17b2b9a342b3229afb6c6a672ea49fcfad.tar.bz2
gentoo-82e65a17b2b9a342b3229afb6c6a672ea49fcfad.zip
dev-python/pytest-xdist: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 8baf152d5910..c21effa5d04b 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,3 +1,4 @@
DIST pytest-xdist-1.33.0.tar.gz 65588 BLAKE2B 096ffa9295ec0ef4d390b714b02a4d126aa33475b55591b91375f2da0c957802e007b990dc2051d5198f223b250a4a7294367c9da8f8969313a61a7e8ef18ebd SHA512 5e5b23e60b546779d4bbcc9b86c004bdb084689ba006c8bb8a7db9be60b6080f04a5bb2b1f5b43a5062b82e35493331d1da699d8a36177307280b06aa23a1367
DIST pytest-xdist-1.34.0.tar.gz 66151 BLAKE2B ac5274e32b3ef6b72113efd4300eb6946a977e0e202d3383abcdbc022126b7806edb326ddc16abb1219e22eb091e06a9c39fce3031aaf5943d4ad653a47af142 SHA512 69e9877ee0268d71d7c0ca202ccc46b3ba1a9271f0e6e4ac4b76602833f9b7012364eb6924ae994e76c1d48d63adf1702d4c5e6ed5b75c52ac7ebae958210e24
DIST pytest-xdist-2.0.0.tar.gz 65663 BLAKE2B 01f4154ae77c0ca67bef9cc0c36f9e3aea03ea554ba45ababb53647720795eae85e6c884eee6cd14037d566dc7bc46f49496aaaecfaaa31322b045339e6c01e8 SHA512 ad1e22ec6963e16f3f1408f0ed39c2945da8f8d2b332b29c36151bc1245e1b9ab532315d8315c22f93f249a64ab508fd78bccd5390be7315d962dd2382f63e0d
+DIST pytest-xdist-2.1.0.tar.gz 66332 BLAKE2B ac3c19a32bb9153537edfcf55bc656011661cf0d166da1aba969055a398616bb5782534a12ba354175be722c070fcfb2013d58405048814a3d11434a314e38b8 SHA512 85c69d8e649a19de5639738eae4cb213dc7323d96883ec82f39ab51a196346edd9fadbaf97f9763ac0dea104bc123d521264a39d2701878edfa76ce7e5bb347b
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.1.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.1.0.ebuild
new file mode 100644
index 000000000000..454164201554
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+# please do not depend on pytest to avoid unnecessary USEDEP enforcement
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv testing || die "Tests failed under ${EPYTHON}"
+}