summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-11-22 21:54:28 -0500
committerMichał Górny <mgorny@gentoo.org>2023-11-23 04:06:58 +0100
commit8d4421e90d39ef7b93063e7fa83addcd84c7ad25 (patch)
tree92f74afed8c69221f58affa40ae454471615a779 /dev-python/pytest-xdist
parentprofiles/base: force USE=gui for =sci-mathematics/giac-1.9.0.67 (diff)
downloadgentoo-8d4421e90d39ef7b93063e7fa83addcd84c7ad25.tar.gz
gentoo-8d4421e90d39ef7b93063e7fa83addcd84c7ad25.tar.bz2
gentoo-8d4421e90d39ef7b93063e7fa83addcd84c7ad25.zip
dev-python/pytest-xdist: remove forced plugin autoload for forked
Followup to commit bc29e400979b556cd9c835a21fa401ec94504c0a. The dependency was removed, but it wasn't also removed from the testsuite loader, which caused pytest to fail early on when it could not find such a plugin to load. As noted in the original commit, it's unused. We certainly shouldn't be autoloading it in the testsuite, then. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Fixes: bc29e400979b556cd9c835a21fa401ec94504c0a Closes: https://github.com/gentoo/gentoo/pull/33939 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.3.1-r1.ebuild2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.4.0.ebuild2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.5.0.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.3.1-r1.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.3.1-r1.ebuild
index 19e75e0e34a0..b82d08ba4afc 100644
--- a/dev-python/pytest-xdist/pytest-xdist-3.3.1-r1.ebuild
+++ b/dev-python/pytest-xdist/pytest-xdist-3.3.1-r1.ebuild
@@ -38,7 +38,7 @@ python_test() {
# disable autoloading plugins in nested pytest calls
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# since we disabled autoloading, force loading necessary plugins
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail
epytest
}
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.4.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.4.0.ebuild
index 441f239a2f03..bf5367bcf383 100644
--- a/dev-python/pytest-xdist/pytest-xdist-3.4.0.ebuild
+++ b/dev-python/pytest-xdist/pytest-xdist-3.4.0.ebuild
@@ -38,7 +38,7 @@ python_test() {
# disable autoloading plugins in nested pytest calls
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# since we disabled autoloading, force loading necessary plugins
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail
epytest
}
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.5.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.5.0.ebuild
index 441f239a2f03..bf5367bcf383 100644
--- a/dev-python/pytest-xdist/pytest-xdist-3.5.0.ebuild
+++ b/dev-python/pytest-xdist/pytest-xdist-3.5.0.ebuild
@@ -38,7 +38,7 @@ python_test() {
# disable autoloading plugins in nested pytest calls
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# since we disabled autoloading, force loading necessary plugins
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail
epytest
}