summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-10 06:14:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-10 06:14:36 +0200
commita8b61fa65bfaaf661980065e45f97069c86bb203 (patch)
treef4231655febcb19bbe1c332f971c74d9af35850d /dev-python/pytest-xdist
parentdev-python/python-nbxmpp: Remove old (diff)
downloadgentoo-a8b61fa65bfaaf661980065e45f97069c86bb203.tar.gz
gentoo-a8b61fa65bfaaf661980065e45f97069c86bb203.tar.bz2
gentoo-a8b61fa65bfaaf661980065e45f97069c86bb203.zip
dev-python/pytest-xdist: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild
deleted file mode 100644
index 7e1cfa8213b4..000000000000
--- a/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Distributed testing and loop-on-failing modes"
-HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-# pytest-xdist >= 2 fails with pytest < 6
-RDEPEND="
- dev-python/execnet[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/filelock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-
-python_test() {
- # disable autoloading plugins in nested pytest calls
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # since we disabled autoloading, force loading necessary plugins
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
-
- distutils_install_for_testing
- epytest
-}