summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-28 11:03:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-28 11:08:00 +0200
commitc832a31b3ee9a7b5b58b1792f8b300aafb2aa81e (patch)
treea976641479f611a91bc3cc8e1ac109054cb13d5b /dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild
parentdev-python/requests: Fix test failures due to listen(0) (diff)
downloadgentoo-c832a31b3ee9a7b5b58b1792f8b300aafb2aa81e.tar.gz
gentoo-c832a31b3ee9a7b5b58b1792f8b300aafb2aa81e.tar.bz2
gentoo-c832a31b3ee9a7b5b58b1792f8b300aafb2aa81e.zip
dev-python/pytest-xprocess: Bump to 0.18.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild')
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild
new file mode 100644
index 000000000000..f2ada45a465d
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest