summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-03 08:40:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-03 09:07:15 +0100
commitac017aeff68c40ddfd2768179dd8814de637335e (patch)
tree68d327a6c68999cda244b4585f0cef16d07dc202 /dev-python/pytest-xprocess
parentdev-python/weasyprint: Bump to 52.3 (diff)
downloadgentoo-ac017aeff68c40ddfd2768179dd8814de637335e.tar.gz
gentoo-ac017aeff68c40ddfd2768179dd8814de637335e.tar.bz2
gentoo-ac017aeff68c40ddfd2768179dd8814de637335e.zip
dev-python/pytest-xprocess: Bump to 0.17.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.17.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index 244a69782e7b..8c017e33ec98 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1 +1,2 @@
DIST pytest-xprocess-0.17.0.tar.gz 19186 BLAKE2B 071063267d88d8ddd56c3b8ab7b2e6bebae321ac741e63336721cd13045688cef56909737c73b5cec27805b4f7dd93cdd7f467071966b3d864d0a1f270e821d0 SHA512 c85bb7bd8373b5b5119083fca46b8f173efe3b6f6cde5db8365e567e717f47f6f9230d2cf5ecfddb014aedd628aee75023f4da3077fa3ffb26b3c7bfc61d57c9
+DIST pytest-xprocess-0.17.1.tar.gz 19758 BLAKE2B 1db4ba7e606caff4591a752cd2a7e368a910ab9b7a28151b1e9c8bdc0f8184a1fa66b23ceb898f1cd7dfbca05b19aeca9a557ab5d3069b8c32ddd9f6f6e75cf6 SHA512 68ee3c8e958f7121d72aca81c32edb7598eb99c3cf6c38fb9c8577ac4860e8241e1da16a44e825204977d6ffa4459fe2742b2ef3b906071a64cd0fcc14920be1
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.17.1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.17.1.ebuild
new file mode 100644
index 000000000000..598a80e97ddf
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.17.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest