summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 12:46:04 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 12:55:35 +0200
commit6e77fafe2368893124a4d0b5d140572e544318b8 (patch)
tree938db4f496a5d1195ca6961a6f2b7737f4ed34db /dev-python/pytest-xvfb
parentdev-python/vncdotool: enable py3.11, pep517 (diff)
downloadgentoo-6e77fafe2368893124a4d0b5d140572e544318b8.tar.gz
gentoo-6e77fafe2368893124a4d0b5d140572e544318b8.tar.bz2
gentoo-6e77fafe2368893124a4d0b5d140572e544318b8.zip
dev-python/pytest-xvfb: update EAPI 7 -> 8, enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
new file mode 100644
index 000000000000..1de8de0246d2
--- /dev/null
+++ b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_REQ_USE="tk"
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A pytest plugin to run Xvfb for tests"
+HOMEPAGE="https://pypi.org/project/pytest-xvfb/"
+SRC_URI="https://github.com/The-Compiler/pytest-xvfb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pyvirtualdisplay-1.3[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+"
+
+distutils_enable_tests pytest