summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-11-13 18:00:59 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-18 22:35:44 +0100
commitbf8a23888c935ac7ca633f7d586b60ea5670f530 (patch)
tree68b67280c7dff67d69e89b20250844705814342e /dev-python/pytest-xvfb
parentdev-qt/qtnetwork: Update minimum dev-libs/openssl version to 1.1.1 (diff)
downloadgentoo-bf8a23888c935ac7ca633f7d586b60ea5670f530.tar.gz
gentoo-bf8a23888c935ac7ca633f7d586b60ea5670f530.tar.bz2
gentoo-bf8a23888c935ac7ca633f7d586b60ea5670f530.zip
dev-python/pytest-xvfb: fix tests
tests do not work at all if the package is not already installed to the system Closes: https://bugs.gentoo.org/754270 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/18246 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
index af48d69b6055..ccf3315e933c 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
@@ -24,6 +24,10 @@ DEPEND="
distutils_enable_tests pytest
python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
+ local -x PYTHONPATH="${BUILD_DIR}/install/lib"
+ esetup.py install \
+ --root="${BUILD_DIR}/install" \
+ --install-lib=lib
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}