summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-09-05 12:21:49 -0400
committerMike Gilbert <floppym@gentoo.org>2016-09-05 12:22:11 -0400
commit1c0ff8413255268a8807036f61c4213973d60f19 (patch)
tree5165353acec0dfaf6399e4b6be3b797120e97377 /dev-python/pytest/pytest-3.0.2.ebuild
parentmedia-libs/mesa: Version bump to 12.0.2 (diff)
downloadgentoo-1c0ff8413255268a8807036f61c4213973d60f19.tar.gz
gentoo-1c0ff8413255268a8807036f61c4213973d60f19.tar.bz2
gentoo-1c0ff8413255268a8807036f61c4213973d60f19.zip
dev-python/pytest: block dev-python/logilab-common
Bug: https://bugs.gentoo.org/592948 Package-Manager: portage-2.3.0_p24
Diffstat (limited to 'dev-python/pytest/pytest-3.0.2.ebuild')
-rw-r--r--dev-python/pytest/pytest-3.0.2.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/pytest/pytest-3.0.2.ebuild b/dev-python/pytest/pytest-3.0.2.ebuild
index 293c43775aec..c28a9884dc4f 100644
--- a/dev-python/pytest/pytest-3.0.2.ebuild
+++ b/dev-python/pytest/pytest-3.0.2.ebuild
@@ -19,15 +19,8 @@ IUSE="test"
# When bumping, please check setup.py for the proper py version
PY_VER="1.4.29"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-
-# dev-python/pluggy
-# https://github.com/hpk42/pluggy
-# See https://github.com/pytest-dev/pytest/issues/944
-# for why not now
-
-#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
-DEPEND="${RDEPEND}
+COMMON_DEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
@@ -36,6 +29,9 @@ DEPEND="${RDEPEND}
dev-python/requests[${PYTHON_USEDEP}]
)
"
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/logilab-common
+"
python_prepare_all() {
chmod o-w *egg*/* || die