summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-07-25 18:12:05 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-07-25 18:28:21 -0700
commit752f7623643670de40a66011906b69da6087f1c0 (patch)
tree5a934b40e9cd2b006c134b3acf380897bf4f42db /dev-python/pytest/pytest-5.0.1.ebuild
parentdev-python/pluggy: bump to 0.12.0 (diff)
downloadgentoo-752f7623643670de40a66011906b69da6087f1c0.tar.gz
gentoo-752f7623643670de40a66011906b69da6087f1c0.tar.bz2
gentoo-752f7623643670de40a66011906b69da6087f1c0.zip
dev-python/pytest: bump to 5.0.1
had to drop a lot of keywords: alpha amd64-fbsd amd64-linux arm arm64 hppa ia64 mips ppc ppc64 s390 sparc sparc-solaris sparc64-solaris x64-solaris x86-linux x86-solaris testsute passes 2346 passed, 50 skipped, 11 xfailed, 1 warnings Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/pytest/pytest-5.0.1.ebuild')
-rw-r--r--dev-python/pytest/pytest-5.0.1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pytest/pytest-5.0.1.ebuild b/dev-python/pytest/pytest-5.0.1.ebuild
new file mode 100644
index 000000000000..b124d68a3a41
--- /dev/null
+++ b/dev-python/pytest/pytest-5.0.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+
+# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
+# support, which only came in py3.6.
+RDEPEND="
+ >=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_5 )
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+
+# flake cause a number of tests to fail
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-40[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-4.5.0-strip-setuptools_scm.patch
+ "${FILESDIR}/${PN}"-5.0.1-test_xfail_rmdir.patch
+)
+
+python_prepare_all() {
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" "${BUILD_DIR}"/lib/pytest.py -vv --lsof -rfsxX \
+ || die "tests failed with ${EPYTHON}"
+}