summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-13 13:38:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-13 15:15:35 +0200
commit03e59429243a89811d3d1791eaaf67a668582d3b (patch)
treed804236fa65037b320bbb3e817fd5377f86a0bcf /dev-python/pytest
parentdev-cpp/kokkos: version bump (diff)
downloadgentoo-03e59429243a89811d3d1791eaaf67a668582d3b.tar.gz
gentoo-03e59429243a89811d3d1791eaaf67a668582d3b.tar.bz2
gentoo-03e59429243a89811d3d1791eaaf67a668582d3b.zip
dev-python/pytest: Bump to 5.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-5.4.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 8e5e03e3ca78..e0c56be1b461 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -3,3 +3,4 @@ DIST pytest-4.5.0.tar.gz 943607 BLAKE2B 49a0e91fda7f4231fdd39f90eb2daa344d3034c1
DIST pytest-4.6.10.tar.gz 951516 BLAKE2B f87d00c3d69990f39369ec6af8c4b88d8b7da9bbdc9fcb324243ea2164a501e1b23d1c2a7f92049b58786fc2f1006673a5b5348e2367a8ca476650623c1f67ed SHA512 73668967f6568654cdf92e260ada79d9685fcfc30967499709caeb12527e39a9e886f057c4c73e8a39125c0fbfcd674d905b7023402ce0ab9e836aa77d3888cb
DIST pytest-4.6.9.tar.gz 956816 BLAKE2B 7eaeaa0d47c17836a35d9cdc97663f8ef65253099b21d60a7ffc3655d8bd93c6b4e33045caa6c8ab9bb8b920b93e596ba86d8eac4ab07b3b7a5989b38312f4fc SHA512 ab45a8662aa798a6ae224ad2cd68e043c605e4830c76cb6c6aca3cfccef232c024cbbb6c48c9bae19148099c339abfef3270a2208cc7e5c37a10b34b0aa6ba79
DIST pytest-5.4.1.tar.gz 1017924 BLAKE2B 2892b06655384c8453963e8444e7c1659f4ce60410afe6d01c480da4858628f6c8fd8774131c5bfaca3b3baf9936e3e4d607788b390d37f7aee90cb39c4ba15c SHA512 50d94158817561316cfb4c6ad4481858a76cfe44ba964cc7a3bb81d3701eb621ca5cd46c4be24644134417d8bf7e7771f4b3a30af71fde5ea9705c3241fa2878
+DIST pytest-5.4.2.tar.gz 1020640 BLAKE2B e10ce7a2dbc1ff42ffbe02c3a9f72b4c829c5cc80ba9a50ae015d181c03916a807ee2b13d40e0d7590844f67f8b68e926c770d298fd839c3cf24d9daa4b4e1e7 SHA512 c92ffa613a02cee2580d690c24b76f16957082b138cf7c51d277b0fb5098fab2272ab73295e5e368cbd908026130a9185a35f8792054e36b7ade0a05f7f3f192
diff --git a/dev-python/pytest/pytest-5.4.2.ebuild b/dev-python/pytest/pytest-5.4.2.ebuild
new file mode 100644
index 000000000000..6e9aec16f996
--- /dev/null
+++ b/dev-python/pytest/pytest-5.4.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="https://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+
+# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
+# support, which only came in py3.6.
+RDEPEND="
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+# flake cause a number of tests to fail
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-4.5.0-strip-setuptools_scm.patch
+)
+
+python_prepare_all() {
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # fragile to warnings from other packages (setuptools)
+ # little value for us to run it
+ sed -i -e 's:test_no_warnings:_&:' \
+ testing/test_meta.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ "${EPYTHON}" -m pytest -vv --lsof -rfsxX \
+ || die "tests failed with ${EPYTHON}"
+}