summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-25 16:57:11 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-25 18:16:36 +0200
commit371df4e919f4c10bca9a5910092855099f18188d (patch)
tree60b4d3082f636228b6afc571dcff5c8fd65b0210 /dev-python/pytest
parentdev-python/py: Port to py3.9 (diff)
downloadgentoo-371df4e919f4c10bca9a5910092855099f18188d.tar.gz
gentoo-371df4e919f4c10bca9a5910092855099f18188d.tar.bz2
gentoo-371df4e919f4c10bca9a5910092855099f18188d.zip
dev-python/pytest: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-4.6.10.ebuild34
-rw-r--r--dev-python/pytest/pytest-5.4.2.ebuild25
2 files changed, 38 insertions, 21 deletions
diff --git a/dev-python/pytest/pytest-4.6.10.ebuild b/dev-python/pytest/pytest-4.6.10.ebuild
index ebd5ee838156..f2ba4fb76432 100644
--- a/dev-python/pytest/pytest-4.6.10.ebuild
+++ b/dev-python/pytest/pytest-4.6.10.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -27,8 +27,9 @@ RDEPEND="
>=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' \
- -2 python3_{5,6,7} pypy3)
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' -2 python3_{5,6,7} pypy3)
$(python_gen_cond_dep '
dev-python/pathlib2[${PYTHON_USEDEP}]
dev-python/funcsigs[${PYTHON_USEDEP}]
@@ -44,17 +45,19 @@ RDEPEND="
DEPEND="
test? (
${RDEPEND}
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ !!dev-python/pytest-aiohttp
+ !!dev-python/pytest-asyncio
+ !!dev-python/pytest-django
+ ' python2_7 python3_{6,7,8} pypy3)
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- !!dev-python/flaky
- !!dev-python/pytest-aiohttp
- !!dev-python/pytest-asyncio
- !!dev-python/pytest-django
)"
PATCHES=(
@@ -72,6 +75,11 @@ python_prepare_all() {
}
python_test() {
+ if [[ ${EPYTHON} == python3.9 ]]; then
+ einfo "Skipping py3.9 due to unported deps"
+ return
+ fi
+
distutils_install_for_testing
# In v4.1.1, pytest started being picky about its own verbosity options.
diff --git a/dev-python/pytest/pytest-5.4.2.ebuild b/dev-python/pytest/pytest-5.4.2.ebuild
index 62074a5c20e2..c53483cbfc67 100644
--- a/dev-python/pytest/pytest-5.4.2.ebuild
+++ b/dev-python/pytest/pytest-5.4.2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -25,7 +25,9 @@ PY_VER="1.5.0"
# support, which only came in py3.6.
RDEPEND="
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_{6,7} pypy3)
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
>=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
@@ -37,12 +39,14 @@ RDEPEND="
# flake cause a number of tests to fail
DEPEND="${RDEPEND}
test? (
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/xmlschema[${PYTHON_USEDEP}]
- !!dev-python/flaky
+ $(python_gen_cond_dep '
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ ' python2_7 python3_{6,7,8} pypy3)
)"
PATCHES=(
@@ -61,6 +65,11 @@ python_prepare_all() {
}
python_test() {
+ if [[ ${EPYTHON} == python3.9 ]]; then
+ einfo "Skipping py3.9 due to unported deps"
+ return
+ fi
+
distutils_install_for_testing
"${EPYTHON}" -m pytest -vv --lsof -rfsxX \