summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-03 21:24:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-03 21:24:01 +0200
commit77eebc053692f00806261bdd31338ec0c084eb13 (patch)
treeaa91464a3463cee319422bb50e330ce79585d898 /dev-python/pytest
parentdev-python/importlib_metadata: Remove old (diff)
downloadgentoo-77eebc053692f00806261bdd31338ec0c084eb13.tar.gz
gentoo-77eebc053692f00806261bdd31338ec0c084eb13.tar.bz2
gentoo-77eebc053692f00806261bdd31338ec0c084eb13.zip
dev-python/pytest: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest2
-rw-r--r--dev-python/pytest/files/pytest-6.2.4-py310.patch34
-rw-r--r--dev-python/pytest/pytest-6.1.2.ebuild62
-rw-r--r--dev-python/pytest/pytest-6.2.4-r1.ebuild64
4 files changed, 0 insertions, 162 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 2c7f84ba17cb..8341a16b4b56 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,4 +1,2 @@
DIST pytest-5.4.3.tar.gz 1022353 BLAKE2B 70d4f23cbbfc4c4ce63c512ee0a01556973761a6d3ebb71a6d9ed4fb4a4a21531e1b151ed0e4c5e56e5dd3243a1a272441f17c4c2c4e3b0b19c24654b74e8e52 SHA512 0a07d4f4f791969c6f21961a0ba0f8c6670e5870c6cc1cebf93766587bb9cb3e10db8e57f0bd33dd22b275f3aad7aa674949f124ac80e0ccca64e35be4beee4e
-DIST pytest-6.1.2.tar.gz 1084943 BLAKE2B cbdf29c54118b5daf699f11fb674d37d5972a163a7a53f42f6ddf9224e2d8d9e84b9a88106d5a77e70f470ccbffb15c2cf9a939be69bc0a2cab1fc4c76054562 SHA512 6335e994c5273881c8d1c334fe6bfa9cd0a3e5c251f3d6a9332f7f7c1427e6560ff48d8f235b307ea5eb53491072daf30c41f566bb67b304354fd88d286c61b1
-DIST pytest-6.2.4.tar.gz 1118084 BLAKE2B 611db50e7432dfb6f8d212621a3803871fd8f6c05ec3cdefeb3958d0886f754326fc358a9a67bdb3f516388aab901b169c951471bf304adfb78fe457dc59d6c5 SHA512 43adc9a78e16a05f07e689e4557b63f2e0f4de5a1cdea6f24272b6a658a6b0a18721713cf46b5102cf2726ddbc4ffe131c39e652bd2511d285f40cbfcccc2289
DIST pytest-6.2.5.tar.gz 1118720 BLAKE2B 9dfc87279617be58353566009325f929e6fa53d54fd4c665a75f3b359ab5415972d745a680eb85ab21ca9eaec84450bc1decd50566b0ccdf90d7551f3d03ee70 SHA512 7624563a9d967da4cbf82cfff90bae8c0cca07b32e291dc7c5efa787725ed1a255edd066bf0d5fbd89b8cbed8cf5b619fe7c7017f44a7f8a014e3310c06bdbf9
diff --git a/dev-python/pytest/files/pytest-6.2.4-py310.patch b/dev-python/pytest/files/pytest-6.2.4-py310.patch
deleted file mode 100644
index 88c8f703f08a..000000000000
--- a/dev-python/pytest/files/pytest-6.2.4-py310.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 78fb97105f38dc286353bbc331a243b6e753fe3c Mon Sep 17 00:00:00 2001
-From: Petr Viktorin <encukou@gmail.com>
-Date: Wed, 6 Jan 2021 13:33:33 +0100
-Subject: [PATCH] Make code.FormattedExcinfo.get_source more defensive
-
-When line_index was a large negative number, get_source failed
-on `source.lines[line_index]`.
-Use the same dummy Source as with a large positive line_index.
----
- src/_pytest/_code/code.py | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/_pytest/_code/code.py b/src/_pytest/_code/code.py
-index b85217560..af3bdf056 100644
---- a/src/_pytest/_code/code.py
-+++ b/src/_pytest/_code/code.py
-@@ -721,11 +721,11 @@ class FormattedExcinfo:
- ) -> List[str]:
- """Return formatted and marked up source lines."""
- lines = []
-- if source is None or line_index >= len(source.lines):
-+ if source is not None and line_index < 0:
-+ line_index += len(source.lines)
-+ if source is None or line_index >= len(source.lines) or line_index < 0:
- source = Source("???")
- line_index = 0
-- if line_index < 0:
-- line_index += len(source)
- space_prefix = " "
- if short:
- lines.append(space_prefix + source.lines[line_index].strip())
---
-2.31.1
-
diff --git a/dev-python/pytest/pytest-6.1.2.ebuild b/dev-python/pytest/pytest-6.1.2.ebuild
deleted file mode 100644
index 21b4753e5aa4..000000000000
--- a/dev-python/pytest/pytest-6.1.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="https://pytest.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_{6,7} pypy3)
- dev-python/iniconfig[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
- <dev-python/pluggy-1
- >=dev-python/py-1.8.2[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
-"
-# flake cause a number of tests to fail
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/xmlschema[${PYTHON_USEDEP}]
- !!dev-python/flaky
- )"
-
-python_prepare_all() {
- # fragile to warnings from other packages (setuptools)
- # little value for us to run it
- sed -i -e 's:test_no_warnings:_&:' \
- testing/test_meta.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
-
- "${EPYTHON}" -m pytest -vv --lsof -rfsxX ||
- die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/pytest/pytest-6.2.4-r1.ebuild b/dev-python/pytest/pytest-6.2.4-r1.ebuild
deleted file mode 100644
index ac093bcc4d5a..000000000000
--- a/dev-python/pytest/pytest-6.2.4-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="https://pytest.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_7 pypy3)
- dev-python/iniconfig[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
- <dev-python/pluggy-1
- >=dev-python/py-1.8.2[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools_scm-3.4[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- $(python_gen_cond_dep '
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/xmlschema[${PYTHON_USEDEP}]
- ' python3_{7..9} pypy3)
- )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-py310.patch
-)
-
-src_test() {
- # workaround new readline defaults
- echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
- local -x INPUTRC="${T}"/inputrc
- distutils-r1_src_test
-}
-
-python_test() {
- [[ ${EPYTHON} == python3.10 ]] && return
-
- distutils_install_for_testing --via-root
-
- "${EPYTHON}" -m pytest -vv --lsof -rfsxX -p no:pkgcore -p no:flaky ||
- die "Tests failed with ${EPYTHON}"
-}