summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-28 22:25:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-28 22:50:28 +0100
commita086ee8b7ea846799b43753e578421c9fee5c8f6 (patch)
treeef3ba3db9c0fb9ffbb628e0451c2f775cafdd2e3 /dev-python/pytest
parentdev-python/pytest: Disable plugin autoload for reliable testing (diff)
downloadgentoo-a086ee8b7ea846799b43753e578421c9fee5c8f6.tar.gz
gentoo-a086ee8b7ea846799b43753e578421c9fee5c8f6.tar.bz2
gentoo-a086ee8b7ea846799b43753e578421c9fee5c8f6.zip
dev-python/pytest: Use epytest to run tests
We have been avoiding epytest so far because it caused test failures. However, it seems that only one test is affected, so just skip it. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-6.2.5-r2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/pytest/pytest-6.2.5-r2.ebuild b/dev-python/pytest/pytest-6.2.5-r2.ebuild
index 4558e9276b96..c55df4717bb1 100644
--- a/dev-python/pytest/pytest-6.2.5-r2.ebuild
+++ b/dev-python/pytest/pytest-6.2.5-r2.ebuild
@@ -55,7 +55,10 @@ python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- "${EPYTHON}" -m pytest -vv --lsof -rfsxX -p xdist \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
- die "Tests failed with ${EPYTHON}"
+ local EPYTEST_DESELECT=(
+ # broken by epytest args
+ testing/test_warnings.py::test_works_with_filterwarnings
+ )
+
+ epytest -p xdist -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
}