summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:22:55 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:48:07 -0500
commit972e01b8906c9fa56e9571ed2dba6c489bcfd65e (patch)
tree3bd798c7440712ee38707ca41d13e5a3e1809842 /dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild
parentdev-python/taskflow: 4.5.0 bump (diff)
downloadgentoo-972e01b8906c9fa56e9571ed2dba6c489bcfd65e.tar.gz
gentoo-972e01b8906c9fa56e9571ed2dba6c489bcfd65e.tar.bz2
gentoo-972e01b8906c9fa56e9571ed2dba6c489bcfd65e.zip
dev-python/python-barbicanclient: 5.0.1 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild')
-rw-r--r--dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild b/dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild
new file mode 100644
index 000000000000..86097bbcfc73
--- /dev/null
+++ b/dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Client library for Barbican API."
+HOMEPAGE="https://github.com/openstack/barbican"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+"