summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-20 12:20:10 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-20 12:29:21 +0100
commit08ad4176f6470227fade4317802f7a0e085152f8 (patch)
tree328a992985017dc689bfe38af17931003641f624 /dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild
parentdev-python/python-magic: Version Bump (diff)
downloadgentoo-08ad4176f6470227fade4317802f7a0e085152f8.tar.gz
gentoo-08ad4176f6470227fade4317802f7a0e085152f8.tar.bz2
gentoo-08ad4176f6470227fade4317802f7a0e085152f8.zip
dev-python/python-bugzilla: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild')
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild b/dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild
new file mode 100644
index 000000000000..f29788a854a3
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"