summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-25 23:51:47 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-25 23:52:08 +0200
commit3785ca3df9a348448eadb6e65cad4902e5467cb4 (patch)
tree4430521bccb6bea50819e559bc03f851aaf19a5a /dev-python/python-ctags
parentdev-python/jaraco-logging: add Python 3.7, verbose tests, drop PyPy (diff)
downloadgentoo-3785ca3df9a348448eadb6e65cad4902e5467cb4.tar.gz
gentoo-3785ca3df9a348448eadb6e65cad4902e5467cb4.tar.bz2
gentoo-3785ca3df9a348448eadb6e65cad4902e5467cb4.zip
dev-python/python-ctags: bump to 1.3.0, adds Python 3.7, EAPI=7
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/python-ctags')
-rw-r--r--dev-python/python-ctags/Manifest1
-rw-r--r--dev-python/python-ctags/python-ctags-1.3.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-ctags/Manifest b/dev-python/python-ctags/Manifest
index d6ab5cac7f94..c59e302937cf 100644
--- a/dev-python/python-ctags/Manifest
+++ b/dev-python/python-ctags/Manifest
@@ -1,2 +1,3 @@
DIST python-ctags3-1.2.3.tar.gz 45646 BLAKE2B 3e8d2044a8c06f903efc02d4fa62a0dc3446426ce716a694b8b3daeba92aec56773f0c02a0a360d15a475b4cac32686f34997b98302198c667137b3c1b093f28 SHA512 3bbe730e75a5ae36208113c6e2c43894942002ee37ed700990416fe54d5644b2d2be795935d1392191aae11797ec613ca143343a287596a0a327027c2f170525
DIST python-ctags3-1.2.4.tar.gz 47774 BLAKE2B 4b1844a6a0d6d89e014206b728e1f1d8b964db2b85afe599cfc254b68f663052d7d1169c257378243e22929297bd254e23ce4c21e1ea1c9a60d7007727c322bf SHA512 db6be08164da71b17de1a7fa46aaa60a5b83784f18ca4e2314e3b9954abe8996d5e07ed98aa024f70899fe87cf53d37671c9f42e567766b4a8af0f728df2bcfb
+DIST python-ctags3-1.3.0.tar.gz 54615 BLAKE2B b334b834cefb01bdbf2c061d44ef6e38070c2b3e5da6de25beb09d24bc9d5891a6892a4b0c9e8fa8f8168bf344c10880ac987e263844cb3dd21303f8c2d105e6 SHA512 3ad4433d69bd159879ff4eface5150acc8c0f609cc7597885824056ce4ec148e55ad234dffa53f07977aa3ace24846e180adce5316a2950ac8d4ff58ad128b68
diff --git a/dev-python/python-ctags/python-ctags-1.3.0.ebuild b/dev-python/python-ctags/python-ctags-1.3.0.ebuild
new file mode 100644
index 000000000000..c676cc532493
--- /dev/null
+++ b/dev-python/python-ctags/python-ctags-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+MY_PN="${PN}3"
+DESCRIPTION="Exuberant Ctags indexing python bindings"
+HOMEPAGE="https://github.com/jonashaag/python-ctags3"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-util/ctags"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ esetup.py test
+}