summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2019-08-14 17:29:09 +0200
committerAaron W. Swenson <titanofold@gentoo.org>2019-10-17 18:15:09 -0400
commit7033cf03516f31603586777683c5d6a65448cd3d (patch)
tree86b64e525c05eba0adb53f965ca93f26ba7c069a /dev-python/python-dateutil/python-dateutil-2.8.0.ebuild
parentwww-client/opera: Old (diff)
downloadgentoo-7033cf03516f31603586777683c5d6a65448cd3d.tar.gz
gentoo-7033cf03516f31603586777683c5d6a65448cd3d.tar.bz2
gentoo-7033cf03516f31603586777683c5d6a65448cd3d.zip
dev-python/python-dateutil: bump 2.8.0
also bump EAPI to 7 Signed-off-by: David Heidelberg <david@ixit.cz> Closes: https://github.com/gentoo/gentoo/pull/12705 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/python-dateutil/python-dateutil-2.8.0.ebuild')
-rw-r--r--dev-python/python-dateutil/python-dateutil-2.8.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-dateutil/python-dateutil-2.8.0.ebuild b/dev-python/python-dateutil/python-dateutil-2.8.0.ebuild
new file mode 100644
index 000000000000..172252195d85
--- /dev/null
+++ b/dev-python/python-dateutil/python-dateutil-2.8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensions to the standard Python datetime module"
+HOMEPAGE="
+ https://dateutil.readthedocs.org/
+ https://pypi.org/project/python-dateutil
+ https://github.com/dateutil/dateutil/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ sys-libs/timezone-data
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/0001-zoneinfo-Get-timezone-data-from-system-tzdata.patch
+ )
+
+ # don't install zoneinfo tarball
+ sed -i '/package_data=/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}