summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-22 20:39:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-22 20:44:16 +0100
commit20f03c434d1c02d799e50538b92bab80fac8b39a (patch)
treefada699690c3b78c061a5e3fe2cb582dede8a7d8 /dev-python/python-dateutil/python-dateutil-2.8.1-r1.ebuild
parentsys-libs/libxcrypt-4.4.11: Version bump, add py38 (diff)
downloadgentoo-20f03c434d1c02d799e50538b92bab80fac8b39a.tar.gz
gentoo-20f03c434d1c02d799e50538b92bab80fac8b39a.tar.bz2
gentoo-20f03c434d1c02d799e50538b92bab80fac8b39a.zip
dev-python/python-dateutil: Remove broken setuptools_scm hack
Closes: https://bugs.gentoo.org/706104 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dateutil/python-dateutil-2.8.1-r1.ebuild')
-rw-r--r--dev-python/python-dateutil/python-dateutil-2.8.1-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-dateutil/python-dateutil-2.8.1-r1.ebuild b/dev-python/python-dateutil/python-dateutil-2.8.1-r1.ebuild
new file mode 100644
index 000000000000..b86e7748cafa
--- /dev/null
+++ b/dev-python/python-dateutil/python-dateutil-2.8.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensions to the standard Python datetime module"
+HOMEPAGE="
+ https://dateutil.readthedocs.org/
+ https://pypi.org/project/python-dateutil
+ https://github.com/dateutil/dateutil/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ sys-libs/timezone-data
+"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0001-zoneinfo-Get-timezone-data-from-system-tzdata-r1.patch"
+ "${FILESDIR}/python-dateutil-2.8.1-no-pytest-cov.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't install zoneinfo tarball
+ sed -i '/package_data=/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ if [[ ${EPYTHON} == python3.7 ]]; then
+ # these tests are flakey on 3.7
+ rm dateutil/test/property/test_{parser,isoparse}_prop.py || die
+ fi
+}