summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-30 07:36:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-30 07:45:40 +0200
commit22c0de4850a13e3237efc5111c85bdffcef38cfc (patch)
tree28bbb44d860132a0e582e2c9a5192d0c7b3ce9f6 /dev-python/python-debian
parentdev-python/nptyping: Bump to 2.3.0 (diff)
downloadgentoo-22c0de4850a13e3237efc5111c85bdffcef38cfc.tar.gz
gentoo-22c0de4850a13e3237efc5111c85bdffcef38cfc.tar.bz2
gentoo-22c0de4850a13e3237efc5111c85bdffcef38cfc.zip
dev-python/python-debian: Bump to 0.1.47
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest1
-rw-r--r--dev-python/python-debian/python-debian-0.1.47.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index 460a88852597..45cad158360a 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1 +1,2 @@
DIST python-debian_0.1.44.tar.xz 179372 BLAKE2B 39d19c46e956231cda7c1fdb3ca89f8ef579d61e6bff06b35114184b2596516b3a01f756ff8e34e9a0dab669658cce7b8fdbfa39ed770df376acf6c4c6fb1401 SHA512 34c627cf32647f196a4b41a8913fd9aaefcfd6c96d21cc8f9798723ac11dac371574f62af9e549437188f2f492cb80445e33f35c72b6fa8212223029371a7b33
+DIST python-debian_0.1.47.tar.xz 189036 BLAKE2B b929b3785064560bbad202d95d88fa330a9fb34e0dc4338865ce17910c9ff986696778dba847097fa1ccbb04ad6b298a5b84e4a550e038ca754a598d78f7cbef SHA512 fdf37476d4658b790ea4bbb43fca43a627cc569881f9e45666eae4221ddb71d57eba7d009e06e8e2864cd41c7718b9bf41e319f6fc0785549b6171de981b6ed7
diff --git a/dev-python/python-debian/python-debian-0.1.47.ebuild b/dev-python/python-debian/python-debian-0.1.47.ebuild
new file mode 100644
index 000000000000..3c07375c1483
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.47.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="
+ https://salsa.debian.org/python-debian-team/python-debian/
+ https://pypi.org/project/python-debian/
+"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ app-arch/dpkg
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # See debian/rules.
+ sed -e "s/__CHANGELOG_VERSION__/${PV}/" lib/debian/_version.py.in \
+ > lib/debian/_version.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # See debian/rules.
+ "${EPYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ eunittest lib
+}