summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-07-23 10:41:46 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-25 19:27:44 +0200
commit3d9aeeca03f967a5061be73e8d9e2ad358e5312f (patch)
treef38c816b881ad1a677c5cc1479bc1d38a73d1d2c /dev-python/python-debian
parentdev-python/readlike: version bump. (diff)
downloadgentoo-3d9aeeca03f967a5061be73e8d9e2ad358e5312f.tar.gz
gentoo-3d9aeeca03f967a5061be73e8d9e2ad358e5312f.tar.bz2
gentoo-3d9aeeca03f967a5061be73e8d9e2ad358e5312f.zip
dev-python/python-debian: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest1
-rw-r--r--dev-python/python-debian/python-debian-0.1.32.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index 19badbe5cf01..917c0ed1a411 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1,2 +1,3 @@
DIST python-debian_0.1.28.tar.xz 292404 BLAKE2B 78634043fc0dabd378bae171a485931b080dc0d31cc7e2ea448c000a1c4250e322f900cf0a0a4c3a8505af6f10da692d0fad948bc253ede7a38e4fe98831924b SHA512 ffbc924fe2dfd5790d49aacf80109bbaa18126bb8d6c9b8ffa25e9ed8b1cdeb28024a8dc202587682088e2e558da1642385faa4afda925cbb2edf6f304592a0d
DIST python-debian_0.1.31.tar.xz 295720 BLAKE2B 3b3a68ab5604571355a15afac181e488c278ca78ab4c8a6cba4c392a0a89fd778bfd37e69a369d50fbc72f5080cf37fdbd31771f5d973c386795c436112ea347 SHA512 d2bf071b088e53ac132f91e5983c092bddb9736b3fd1394dfd2654fb8b6af7f89982af8debba8c4af21086d4f8a3ef86393fdef25ef18bcf71dcb00a60a8ae5b
+DIST python-debian_0.1.32.tar.xz 296028 BLAKE2B 15e2678a1ec2f4d96baec8b9e3ce7b84d8ad37f520fe9f174d6fe9cac8adbcbb73f628d9c3cdf39eca2639855e797b8f8cef4c9517063d61aa1e3b3ce7f1df2c SHA512 2b55d9a3100028699ec63dd4861a4f60d44e03662cc144784a37cdd980f3ff276e6cd2e535a50cdc6db28bf44affdd576259d73e14e16a2bbeeeda0de0bdd194
diff --git a/dev-python/python-debian/python-debian-0.1.32.ebuild b/dev-python/python-debian/python-debian-0.1.32.ebuild
new file mode 100644
index 000000000000..03133f9a7a5e
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.32.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="https://packages.debian.org/sid/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( app-arch/dpkg )"
+
+RESTRICT="test"
+
+python_prepare_all() {
+ sed -i -e '/import apt_pkg/d' \
+ -e 's/test_iter_paragraphs_comments_use_apt_pkg/_&/' \
+ lib/debian/tests/test_deb822.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover lib || die "Testing failed with ${EPYTHON}"
+}