summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-08-06 15:04:50 -0400
committerMike Gilbert <floppym@gentoo.org>2016-08-06 15:07:05 -0400
commit414ee1f769606b142c6c04d5d610091defacc505 (patch)
tree4fc62ef0adbc834a9653621bee07d68780314ed6 /dev-python/python-debian
parentdev-libs/libgit2: Version bump to 0.24.1 (diff)
downloadgentoo-414ee1f769606b142c6c04d5d610091defacc505.tar.gz
gentoo-414ee1f769606b142c6c04d5d610091defacc505.tar.bz2
gentoo-414ee1f769606b142c6c04d5d610091defacc505.zip
dev-python/python-debian: bump to 0.1.28
Package-Manager: portage-2.3.0_p16
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest1
-rw-r--r--dev-python/python-debian/python-debian-0.1.28.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index 5f894bddda9b..f6127ca6af78 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1,2 +1,3 @@
DIST python-debian_0.1.26.tar.xz 289496 SHA256 601e2a096c1490669f35080544875857bdc54b5f43bf1a37f88fccbf3740b4f8 SHA512 c857bdeaf651626c1b9d1f0f114bae961d073771f0a38caaa06785323bd586cf15fd2bf662a7bdc3af148f387756260b9d81378fdd5044bfabf7388de79c4d5a WHIRLPOOL 1dcf9a855e75ed483551edffba72265878208f3e55adf9e206bb79ac8462c1186251231f97368b1673ff73a3c38f6c5cf37195480fe010b2b7199e829317a4d3
DIST python-debian_0.1.27.tar.xz 289692 SHA256 3a21d07553d46c0cf7961b13483e62005d8793a3780e79d1191b357f50174eab SHA512 101f49ce2337266856f6cf8f6d33c42d9fa2a281194a7d6fb2328d6e5f46574a7b742b04c4250e2384c197c6e6886c0e9f7b504e8c2230afaa00777e1a0057ab WHIRLPOOL f8b867fbbd236d685acbdf880bf636efb59f033788365aeea52e898217735bd0117526c2f67cfe9205d3f31b5d8da68eb5e6e6ec1ad2920a2ed0d4d54616c38f
+DIST python-debian_0.1.28.tar.xz 292404 SHA256 355edeaa0e2d5a46e4b12c83c7a17386526af4fee34c1d4054fc03bd4f0adf00 SHA512 ffbc924fe2dfd5790d49aacf80109bbaa18126bb8d6c9b8ffa25e9ed8b1cdeb28024a8dc202587682088e2e558da1642385faa4afda925cbb2edf6f304592a0d WHIRLPOOL 6f1778dd6839459e86179f5f02ba0a6e69154efcfc034c1d554d940409e974b57c73839853c86b14d840f27c6a0666a11618f51a125922e58596f28aa888c8ca
diff --git a/dev-python/python-debian/python-debian-0.1.28.ebuild b/dev-python/python-debian/python-debian-0.1.28.ebuild
new file mode 100644
index 000000000000..157e2a799c74
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.28.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="http://packages.debian.org/sid/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( app-arch/dpkg )"
+
+RESTRICT="test"
+
+python_compile_all() {
+ "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ # Tests currently fail with >=app-crypt/gnupg-2.1
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782904
+ pushd tests > /dev/null || die
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+ popd > /dev/null || die
+}