summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-13 16:33:37 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-13 16:33:37 -0500
commit96e447a335d509d6f5f1318c5989cd257ffa280b (patch)
treeae2b340d55cdb1013a61551498410d63e8374231 /dev-python/python-debian
parentprofiles/package.mask: mask net-misc/arm for removal in 30 days (diff)
downloadgentoo-96e447a335d509d6f5f1318c5989cd257ffa280b.tar.gz
gentoo-96e447a335d509d6f5f1318c5989cd257ffa280b.tar.bz2
gentoo-96e447a335d509d6f5f1318c5989cd257ffa280b.zip
dev-python/python-debian: bump 0.1.31
Package-Manager: Portage-2.3.13_p7, Repoman-2.3.3_p87
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest1
-rw-r--r--dev-python/python-debian/python-debian-0.1.28.ebuild4
-rw-r--r--dev-python/python-debian/python-debian-0.1.31.ebuild41
3 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index 8f15bd167d3d..55f23449dc14 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1 +1,2 @@
DIST python-debian_0.1.28.tar.xz 292404 SHA256 355edeaa0e2d5a46e4b12c83c7a17386526af4fee34c1d4054fc03bd4f0adf00 SHA512 ffbc924fe2dfd5790d49aacf80109bbaa18126bb8d6c9b8ffa25e9ed8b1cdeb28024a8dc202587682088e2e558da1642385faa4afda925cbb2edf6f304592a0d WHIRLPOOL 6f1778dd6839459e86179f5f02ba0a6e69154efcfc034c1d554d940409e974b57c73839853c86b14d840f27c6a0666a11618f51a125922e58596f28aa888c8ca
+DIST python-debian_0.1.31.tar.xz 295720 SHA256 942968340c5b8fbabe89f1081940ec7baeca0cdbd7f82bdcbda98da511ce35b3 SHA512 d2bf071b088e53ac132f91e5983c092bddb9736b3fd1394dfd2654fb8b6af7f89982af8debba8c4af21086d4f8a3ef86393fdef25ef18bcf71dcb00a60a8ae5b WHIRLPOOL 1edd2ac1d1aa3d45d591c7f1a40f02243b188f4299cd781aa043168e9cf05ffa3dcba3ee742446835eaaa35a3cf8b4a42a3e0d39350ce99ee24f4d3b3055b779
diff --git a/dev-python/python-debian/python-debian-0.1.28.ebuild b/dev-python/python-debian/python-debian-0.1.28.ebuild
index ba4f1f045850..427a310a47e1 100644
--- a/dev-python/python-debian/python-debian-0.1.28.ebuild
+++ b/dev-python/python-debian/python-debian-0.1.28.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
inherit distutils-r1
DESCRIPTION="Python modules to work with Debian-related data formats"
-HOMEPAGE="http://packages.debian.org/sid/python-debian"
+HOMEPAGE="https://packages.debian.org/sid/python-debian"
SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
LICENSE="GPL-2 GPL-3"
diff --git a/dev-python/python-debian/python-debian-0.1.31.ebuild b/dev-python/python-debian/python-debian-0.1.31.ebuild
new file mode 100644
index 000000000000..d563a839202d
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.31.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="https://packages.debian.org/sid/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( app-arch/dpkg )"
+
+RESTRICT="test"
+
+python_prepare_all() {
+ sed -i -e '/import apt_pkg/d' \
+ -e 's/test_iter_paragraphs_comments_use_apt_pkg/_&/' \
+ lib/debian/tests/test_deb822.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover lib || die "Testing failed with ${EPYTHON}"
+}