summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-15 08:50:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-15 10:04:00 +0200
commitbbad117d7782c42f4f29c59b35808034f3b7aa24 (patch)
tree66f749415131eadc3b6d041e63c77d4518d241c9 /dev-python/python-debian
parentapp-admin/awscli: Bump to 1.25.92 (diff)
downloadgentoo-bbad117d7782c42f4f29c59b35808034f3b7aa24.tar.gz
gentoo-bbad117d7782c42f4f29c59b35808034f3b7aa24.tar.bz2
gentoo-bbad117d7782c42f4f29c59b35808034f3b7aa24.zip
dev-python/python-debian: Bump to 0.1.48
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest1
-rw-r--r--dev-python/python-debian/python-debian-0.1.48.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index 61789bc93890..13714ea5f0aa 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1 +1,2 @@
DIST python-debian_0.1.47.tar.xz 189036 BLAKE2B b929b3785064560bbad202d95d88fa330a9fb34e0dc4338865ce17910c9ff986696778dba847097fa1ccbb04ad6b298a5b84e4a550e038ca754a598d78f7cbef SHA512 fdf37476d4658b790ea4bbb43fca43a627cc569881f9e45666eae4221ddb71d57eba7d009e06e8e2864cd41c7718b9bf41e319f6fc0785549b6171de981b6ed7
+DIST python-debian_0.1.48.tar.xz 189096 BLAKE2B 3b273f1e90069e00a93aeb9c2333d20d479b057613c93325344f42a73230bd569160a487a25d1c7f90f7f00f42feeab55c9850cf44121e1ca423cd1f40a991a4 SHA512 85bd12ce8ade9b43d502bd60ac1ac826d9a81b5bf32262ff9377b4ba5a1c95306683098d10a64fd6a1331ed7eb44a7fb09ad90f0ee6c885d69ea16f85c4eda59
diff --git a/dev-python/python-debian/python-debian-0.1.48.ebuild b/dev-python/python-debian/python-debian-0.1.48.ebuild
new file mode 100644
index 000000000000..3c07375c1483
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.48.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="
+ https://salsa.debian.org/python-debian-team/python-debian/
+ https://pypi.org/project/python-debian/
+"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ app-arch/dpkg
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # See debian/rules.
+ sed -e "s/__CHANGELOG_VERSION__/${PV}/" lib/debian/_version.py.in \
+ > lib/debian/_version.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # See debian/rules.
+ "${EPYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ eunittest lib
+}