summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 23:16:49 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 23:45:39 -0600
commitf38fe3f3fd8744d4d846e9d00348ac3d352cf93b (patch)
tree3e69c408fc724b3559075dd33352278c6e75e64f /dev-python/python-designateclient/python-designateclient-2.6.0.ebuild
parentdev-python/weakrefmethod: initial add (diff)
downloadgentoo-f38fe3f3fd8744d4d846e9d00348ac3d352cf93b.tar.gz
gentoo-f38fe3f3fd8744d4d846e9d00348ac3d352cf93b.tar.bz2
gentoo-f38fe3f3fd8744d4d846e9d00348ac3d352cf93b.zip
dev-python/python-designateclient: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/python-designateclient/python-designateclient-2.6.0.ebuild')
-rw-r--r--dev-python/python-designateclient/python-designateclient-2.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-designateclient/python-designateclient-2.6.0.ebuild b/dev-python/python-designateclient/python-designateclient-2.6.0.ebuild
new file mode 100644
index 000000000000..f8e61dc74616
--- /dev/null
+++ b/dev-python/python-designateclient/python-designateclient-2.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the Designate API."
+HOMEPAGE="https://github.com/openstack/python-designateclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/cliff-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]"