summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-22 12:54:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-22 17:35:35 +0200
commit73c94bc429d4502c9aa0157a05679da7b96f933f (patch)
treeb83ac1e917ebdbdc05f79035366723fdab290647 /dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild
parentsci-mathematics/wxmaxima: bump to 20.06.6 (diff)
downloadgentoo-73c94bc429d4502c9aa0157a05679da7b96f933f.tar.gz
gentoo-73c94bc429d4502c9aa0157a05679da7b96f933f.tar.bz2
gentoo-73c94bc429d4502c9aa0157a05679da7b96f933f.zip
dev-python/python-distutils-extra: Bump to 2.45
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild')
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild
new file mode 100644
index 000000000000..426f03e80fb7
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="
+ https://salsa.debian.org/python-team/modules/python-distutils-extra
+ https://launchpad.net/python-distutils-extra"
+SRC_URI="
+ https://salsa.debian.org/python-team/modules/python-distutils-extra/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( doc/{README,FAQ} )
+
+BDEPEND="
+ test? (
+ dev-libs/gobject-introspection
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-util/intltool
+ )"
+
+python_test() {
+ "${EPYTHON}" test/auto.py -v || die "Tests fail with ${EPYTHON}"
+}