summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-20 02:05:10 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-20 19:41:16 +0100
commitd8980181a9dbdac711c70504984e20c40d9c5fb2 (patch)
tree89e004ba9a21f364c3b7b981162fc4cbb622d887 /dev-python/python-distutils-extra
parentx11-drivers/xf86-video-intel: Remove old (diff)
downloadgentoo-d8980181a9dbdac711c70504984e20c40d9c5fb2.tar.gz
gentoo-d8980181a9dbdac711c70504984e20c40d9c5fb2.tar.bz2
gentoo-d8980181a9dbdac711c70504984e20c40d9c5fb2.zip
dev-python/python-distutils-extra: bump to 2.39, add py3.5, pypy3
Also update LICENSE, remove useless DISTUTILS_IN_SOURCE_BUILD, use pytest to exclude broken tests, bump to EAPI=6. Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3555
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/Manifest1
-rw-r--r--dev-python/python-distutils-extra/metadata.xml1
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild55
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/Manifest b/dev-python/python-distutils-extra/Manifest
index f007fc125ddc..8bf16605eb74 100644
--- a/dev-python/python-distutils-extra/Manifest
+++ b/dev-python/python-distutils-extra/Manifest
@@ -1 +1,2 @@
DIST python-distutils-extra-2.38.tar.gz 27748 SHA256 3d100d5d3492f40b3e7a6a4500f71290bfa91e2c50dc31ba8e3ff9b5d82ca153 SHA512 bbaea59a8f251f354e6cf3799b67c12225095cc869c7c4e299e719ad7bcfd1292cff99f95ab25f04fb9c3e2432da5ea614ee76154781388c47960fdf2c90a3d7 WHIRLPOOL 10ca7754985aa634aaef7f7fc80777ca4a2b79ecc11e80c48bb2e6c1765cc9f38fbf9696957f974533f50f06db3d1bdb6527f1ed6dbe05619f3d0a17184b885d
+DIST python-distutils-extra-2.39.tar.gz 27389 SHA256 723f24f4d65fc8d99b33a002fbbb3771d4cc9d664c97085bf37f3997ae8063af SHA512 e3b4d1ed22767fb4c6dbbdccef960865b6fda01d18dc38cb8f9357c09c7eabb78466fce053e407a196eca257d07d57c5c1ef47f358a5979c7f22e4b11775124e WHIRLPOOL a485aa70267eaed03dc1174b73ab482ae409aeed5fcbbe82ab4ab377d8a8f91e1fa8aa3b9bb9af8c9b6bc3bc306284974d99943473afdce7f1d6b7322edd0623
diff --git a/dev-python/python-distutils-extra/metadata.xml b/dev-python/python-distutils-extra/metadata.xml
index ea8f049227c3..930ec08cf4e8 100644
--- a/dev-python/python-distutils-extra/metadata.xml
+++ b/dev-python/python-distutils-extra/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="launchpad">python-distutils-extra</remote-id>
+ <bugs-to>https://bugs.launchpad.net/python-distutils-extra</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild
new file mode 100644
index 000000000000..d039db315c65
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( doc/{README,FAQ} )
+
+python_prepare_all() {
+ # This line is run when the file is imported
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1657919
+ sed -i '/^unittest.main()$/d' test/auto.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # 5 tests fail with disabled byte-compilation (they rely on exact
+ # output from python).
+ # The other 4 are broken.
+ py.test -k "not (test_pot_manual or test_pot_auto_explicit or \
+ test_pot_auto or test_modules or test_packages) and not \
+ (test_desktop or test_po or test_policykit or \
+ test_requires_provides)" test/auto.py || \
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ docinto examples
+ dodoc doc/{setup.cfg.example,setup.py.example}
+ docompress -x /usr/share/doc/${PF}/examples
+}