summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-05 15:42:28 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-05 16:11:44 +0200
commitf952ff0542696f623ca1686f3e185c2317159722 (patch)
tree4dcc9ed704b2dedc4a94cb58cca4106a9e4bbc75 /dev-python/python-distutils-extra
parentapp-metrics/collectd: fix missing group in init script (diff)
downloadgentoo-f952ff0542696f623ca1686f3e185c2317159722.tar.gz
gentoo-f952ff0542696f623ca1686f3e185c2317159722.tar.bz2
gentoo-f952ff0542696f623ca1686f3e185c2317159722.zip
dev-python/python-distutils-extra: Bump to 2.46
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/Manifest1
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/Manifest b/dev-python/python-distutils-extra/Manifest
index beb806cef343..6cf1d54b5c1a 100644
--- a/dev-python/python-distutils-extra/Manifest
+++ b/dev-python/python-distutils-extra/Manifest
@@ -1 +1,2 @@
DIST python-distutils-extra-2.45.tar.bz2 38094 BLAKE2B b8c0adcb92d07e087e10389c9671e9eca78a9a634d0092c1633e184fb9d128b006903ce8f2c9deb504b3d1557a8afc78e3edea7f1a2e95734c55099b4a21dd41 SHA512 04d2be290726d7ceed599031bfa960468c6a8654c8d9105dd77cb5744f6908d1c9a6732095692aebde1f1e042ef70b2695d41586663e4d539ee96247a39f02a1
+DIST python-distutils-extra-2.46.tar.bz2 38178 BLAKE2B 66bded2a07a65a45e7b5a36c1846a0927db8cc38c158754c660ea854244736325b9b186de1739666e228199b32ff6184676a78f132689a996a9a417562dc0926 SHA512 78dd97f40e805dd106fae279770fbd28af75a01a0c514cdb937dccd87948cb8ae2413dbab43d624365b44a29e6da7b0a1290502a0a0d63e8abb700ae9b9c5cb1
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild
new file mode 100644
index 000000000000..5e898d180bee
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="
+ https://salsa.debian.org/python-team/packages/python-distutils-extra/
+ https://launchpad.net/python-distutils-extra/
+"
+SRC_URI="
+ https://salsa.debian.org/python-team/packages/python-distutils-extra/-/archive/${PV}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( doc/{README,FAQ} )
+
+BDEPEND="
+ test? (
+ dev-libs/gobject-introspection
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-util/intltool
+ )
+"
+
+python_test() {
+ "${EPYTHON}" test/auto.py -v || die "Tests fail with ${EPYTHON}"
+}